Global DNS Failures
Incident Report for Gradwell Communications Ltd
Resolved
Hello,

Google has confirmed they are investigating and all services have since been stable.

If you are still experiencing any issues, please call our support team for further investigation.
Posted Aug 12, 2024 - 17:13 BST
Investigating
Hello,

We are currently investigating reports of a global DNS outage, which we believe may be linked to Google's DNS servers. However, it appears that other server providers are also affected. Our team is working to determine the exact cause of the issue.

Please accept our apologies for the inconvenience caused.
Posted Aug 12, 2024 - 14:59 BST
This incident affected: Connectivity (Fibre line, EFM, ADSL Broadband, FTTC, Phone lines) and Voice & Calls Services (DNS Services, Hosted 3CX Server).