Draytek Hardware Issues

Incident Report for Gradwell Communications Ltd

Resolved

This incident has been resolved.
Posted 5 days ago. Mar 26, 2025 - 09:42 GMT

Update

We can confirm that firmware upgrades on Draytek routers have resolved connectivity issues where applied. If you are still experiencing issues with your connectivity when using a Draytek router, please ensure your firmware is upgraded to the latest version. We will continue to monitor the situation until March 25th.
Posted 7 days ago. Mar 24, 2025 - 17:39 GMT

Monitoring

We are aware of a number of reports of issues with broadband circuits, this has been identified as affecting circuits using Draytek routers where an issue with the routers is causing them to regularly power cycle, resulting in connections being dropped whilst this is happening. We are advising to upgrade to the latest Drayek firmware. Please refer to the Draytek website for this https://www.draytek.com/support/resources/routers#version
Posted 7 days ago. Mar 24, 2025 - 09:39 GMT
This incident affected: Connectivity (Fibre line, EFM, ADSL Broadband, FTTC, Phone lines).