Wave Outage

Incident Report for Gradwell Communications Ltd

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 11:26 BST

Investigating

We want to inform you that an issue impacting Wave’s calling functionality has now been resolved. Earlier, users experienced difficulties making or receiving calls. Our teams worked swiftly to identify and resolve the problem, and normal service has been fully restored.

We understand how critical Wave is for your communication needs, and we sincerely apologise for any inconvenience this may have caused. To provide full transparency, we will publish a Reason for Outage (RFO) report within five working days.

If you continue to experience any issues or have questions, please don’t hesitate to contact our support team at support@gradwell.com or call 01225 800888.
Posted Mar 31, 2025 - 12:40 BST
This incident affected: Voice & Calls Services (Wave).